Firmware update via Modal app apparently fried the USB port on my Argon8

This is what I’d ba seeing on my laptop if I could still connect via USB. Photo courtesy Sound On Sound

Earlier this month I lugged my new Argon8 wavetable synthesizer to Mono Lake to do some recording.  I hooked it up via USB to my laptop, and fired up the Modal app for some patch editing. The app informed me a firmware update was available, so I downloaded it.

The synth was updated in less than 90 seconds. No problems.

Except the Modal app and my laptop no longer recognized the USB connection to the Argon8.

I rebooted everything. No luck. The Argon8 didn’t show up in the MIDI panel on the laptop. Hitting “refresh” on the app did nothing. Reinstalling the app did nothing. Running the firmware update again did nothing. The app still couldn’t find the synth.

The synth worked fine. The reason I brought it on the trip, however, was to modify factory patches. It’s reasonably easy with the app, but since the app wasn’t finding the synth, I had to do it the old-fashioned way: twisting knobs and saving custom presets.

I went back and forth with Modal support in the UK over the course of a week. They were patient and helpful, but finally told me they suspected the USB card on the Argon8 was hosed. They admitted this had never happened before. They offered to put me in touch with their US distributor, Voltage, but I never heard from the latter, and I’d already talked with Sweetwater, the reseller who originally shipped me the synthesizer.

There was no delay and no fuss — Sweetwater sent me a new replacement Argon8 immediately, along with a prepaid return label for the defective unit.

All that’s left to do is dump my custom presets as SysEx data so I can load them on the replacement unit when it arrives.

Thank you, Sweetwater (and Modal), for a fairly painless resolution to a situation that could’ve been a much bigger ordeal.

UPDATE (March 25, 2020): Let’s just say the process isn’t / wasn’t as “fairly painless” as I’d hoped. I can’t figure out how to dump the sysex patch data over MIDI without the Modal app — and, apparently, Sweetwater can’t either. Voltage, Modal’s US distributor, and Modal UK aren’t answering support requests. Hope to hear back from at least one of the three entities in the next day or so.

UPDATE (March 26, 2020): Voltage, Modal’s US distributor, didn’t “reach out” as Modal said they would on March 17. I sent Voltage a followup request on March 25, and another on the 26th, with no answer, no acknowledgment or autoreply.

I’d received some info from Sweetwater and, today, finally, Modal (after opening up yet another ticket) regarding getting the patch data off the defective unit using SysEx Librarian. The recommended process seemed like it was missing a step or two, but I tried anyway, in several different ways.

But after hours of various attempts to dump the sysex patch data into a laptop running SysEx Librarian with no luck, I’m giving Modal support one more day to see if they respond with more details. This has been going on since March 10, so it seems I’m jumping through all the requested hoops.

UPDATE (March 27, 2020): I’m returning both the defective Argon8 synth and the replacement for credit at Sweetwater. Their warehouse is currently closed due to the coronavirus outbreak. When it reopens and the units are received, I’ll buy another synth, most likely a KORG wavestate.